Comment arrondir un nombre sur Excel (mise-en-forme ou formule : la bonne méthode)

Dans ce tutoriel, je vais vous montrer comment arrondir un nombre sur Excel, c’est-à-dire définir un nombre de décimales à afficher derrière la virgule. Pour cela, nous allons étudier plusieurs méthodes reposant sur de la mise en forme ou l’utilisation de formule, en relavant les avantages et les inconvénients de chacune de ces méthodes.

 

Pour suivre cet article dans les meilleures conditions, je vous invite à télécharger le fichier en suivant le lien disponible ci-dessous :

 

Téléchargement

 

Vous pouvez télécharger le fichier d'exemple de cet article en cliquant sur le lien suivant :

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.
 

 

1. Présentation

Pour illustrer ce tutoriel, nous disposons d’une table reprenant différents articles avec leur prix d’achat exprimé en dollar :

Excel formation - Comment arrondir un nombre sur Excel - 01

Nous disposons également du taux de conversion utilisé au moment même de l’achat de ces marchandises

Pour obtenir l’équivalent du prix d’achat, exprimé cette fois-ci en euro, il suffit de multiplier chacun de ces prix par le taux de conversion :

 =B9*$E$6

 

Excel formation - Comment arrondir un nombre sur Excel - 02

Attention, de prendre la référence absolue des coordonnées de la cellule contenant le taux de conversion afin de pouvoir étendre convenablement la formule sur les cellules du dessous (d’où la présence du symbole dollar dans la formule, qui s’obtient en appuyant sur la touche [F4] du clavier).

Enfin, pour récupérer le montant total des achats en euro, il suffit d’appliquer la formule somme sur l’ensemble des articles :

 =SOMME(C9:C14)

 

Excel formation - Comment arrondir un nombre sur Excel - 03

Le problème auquel nous sommes ici confrontés, c’est que les nombres sont affichés avec de nombreuses décimales.

 

2. Utiliser un format

 

La première possibilité qui s’offre alors à nous, c’est de conserver la valeur numérique telle qu’elle est ici calculée, mais de n’afficher qu’un nombre limité de décimales.

Pour cela, nous sélectionnons les cellules concernées, puis dans le menu Accueil du ruban, nous choisissons simplement le Format Nombre Comptabilité :

Excel formation - Comment arrondir un nombre sur Excel - 04

De cette manière, Excel affiche deux décimales, ainsi que le symbole euro.

Il est également possible de définir précisément le nombre de décimal à afficher, en effectuant un clic-droit, puis Format de cellule :

Excel formation - Comment arrondir un nombre sur Excel - 05

Dans la catégorie Nombre, nous pouvons ainsi choisir d’afficher quatre décimales :

Excel formation - Comment arrondir un nombre sur Excel - 06

Attention, il est important de bien comprendre que seul l’affichage à l’écran est ici modifié, et qu’Excel conserve en mémoire l’ensemble des décimales. Pour s’en rendre compte, il suffit de cliquer sur une des cellules modifiées, puis de d’appuyer sur la touche [F2] pour entrer dans la barre des formules, puis sur la touche [F9] pour afficher la valeur de la cellule :

Excel formation - Comment arrondir un nombre sur Excel - 07

Un certain nombre d’anomalies peuvent ainsi se présenter, notamment lorsque l’on calcul manuellement la somme des valeurs présentées (par exemple à l’aide de la calculatrice de Windows) :

Excel formation - Comment arrondir un nombre sur Excel - 08

C’est par exemple ce qui peut expliquer les erreurs de comptabilisation sur certaines factures crées sur Excel (avec notamment des arrondis au niveau des calculs de TVA).

Pour corriger ce problème, la solution consiste à arrondir directement la valeur des données de chaque ligne en utilisant une formule.

 

3. Utiliser les formules d’arrondi

 

Afin de permettre un choix important quant aux différents arrondis, Excel propose plusieurs formules ayant chacune des effets différents :

Excel formation - Comment arrondir un nombre sur Excel - 09

 

   3.1. La formule ARRONDI()

 

La formule ARRONDI() permet d’arrondir un nombre à x décimales, en fonction de la règle de l’arrondi à la valeur la plus proche qui prévoit d’arrondir un nombre à la valeur inférieure lorsque le chiffre situé juste après est compris entre 0 et 4, et à la valeur supérieure lorsque ce dernier est compris entre 5 et 9.

 =ARRONDI(nombre;no_chiffres) 

 
  • nombre : il s’agit du nombre initial que l’on souhaite arrondir,
  • no_chiffres : il s’agit de la force de l’arrondi, c’est-à-dire du nombre de chiffres après l’arrondi que l’on souhaite obtenir. Pour arrondir un chiffre à la dizaine, il faudra utiliser un nombre négatif
=ARRONDI(1023,541;2)       → 1023,54 
=ARRONDI(1023,547;2)       → 1023,55 
=ARRONDI(1023,547;-1)      → 1020

Pour continuer sur notre exemple, en utilisant la formule ARRONDI(), à deux décimales :

 

Excel formation - Comment arrondir un nombre sur Excel - 10

Cette fois-ci le total est effectivement égal à 3 119.86€.

 

   3.2. La formule ARRONDI.INF()

 

La formule ARRONDI.INF() permet d’arrondir un nombre à x décimales, en fonction de la règle de l’arrondi à la valeur inférieure. Cette formule fonctionne de la même manière que la formule TRONQUE() et renverra le même résultat.

 =ARRONDI.INF(nombre;no_chiffres) 

 

  • nombre : il s’agit du nombre initial que l’on souhaite arrondir,
  • no_chiffres : il s’agit de la force de l’arrondi, c’est-à-dire du nombre de chiffres après l’arrondi que l’on souhaite obtenir. Pour arrondir un chiffre à la dizaine, il faudra utiliser un nombre négatif

 

=ARRONDI.INF(1023,541;2)       → 1023,54
=ARRONDI.INF(1023,547;2)       → 1023,54
=ARRONDI.INF(1023,547;-1)      → 1020

Excel formation - Comment arrondir un nombre sur Excel - 11

 

   3.3. La formule ARRONDI.SUP()

 

La formule ARRONDI.SUP() permet d’arrondir un nombre à x décimales, en fonction de la règle de l’arrondi à la valeur supérieure.

 =ARRONDI.SUP(nombre;no_chiffres) 

 
  • nombre : il s’agit du nombre initial que l’on souhaite arrondir,
  • no_chiffres : il s’agit de la force de l’arrondi, c’est-à-dire du nombre de chiffres après l’arrondi que l’on souhaite obtenir. Pour arrondir un chiffre à la dizaine, il faudra utiliser un nombre négatif
=ARRONDI.SUP(1023,541;2)       → 1023,55
=ARRONDI.SUP(1023,547;2)       → 1023,55
=ARRONDI.SUP(1023,547;-1)      → 1030

 

Excel formation - Comment arrondir un nombre sur Excel - 12

 

   3.4. La formule ARRONDI.AU.MULTIPLE()

 

La formule ARRONDI.AU.MULTIPLE() permet d’arrondir un nombre en fonction d’un multiple que l’utilisateur peut librement spécifier. Cela permet par exemple de regrouper des séries de chiffres par groupe

 

 =ARRONDI.AU.MULTIPLE(nombre;multiple) 
  • nombre : il s’agit du nombre initial que l’on souhaite arrondir,
  • multiple : il s’agit du multiple auquel le nombre va être arrondi

 

=ARRONDI.AU.MULTIPLE(18;5)       → 20
=ARRONDI.AU.MULTIPLE(48;5)       → 50
=ARRONDI.AU.MULTIPLE(61;5)       → 65

Cet exemple permet par exemple de réaliser une pyramide des âges en regroupant les groupes d’âges les uns avec les autres, en utilisant un multiple de 5.

Excel formation - Comment arrondir un nombre sur Excel - 13

Note : les formules PLAFOND.MATH() et PLANCHER.MATH() fonctionnent de la même manière que la formule ARRONDI.AU.MULTIPLE() :

  • La formule PLAFOND.MATH() renvoie exactement le même résultat que la formule ARRONDI.AU.MULTIPLE(), et s’utilise d’ailleurs de la même manière,

Excel formation - Comment arrondir un nombre sur Excel - 14

  • La formule PLANCHER.MATH() renvoie quant à elle un résultat arrondi au multiple inférieur,

Excel formation - Comment arrondir un nombre sur Excel - 15

 

=PLAFOND.MATH(18;5)      → 20
=PLANCHER.MATH(18;5)     → 15


 



Articles qui pourraient vous intéresser

La fonction SOMME.SI

Comment calculer une différence entre deux dates avec la formule DATEDIF (années, mois ou jours) sur EXCEL

Comment utiliser les formules DATE(), JOUR(), MOIS() et ANNEE() pour (dé)composer une date sur EXCEL

Comment vérifier que deux cellules sont identiques et forcer la saisie en MAJUSCULES sur Excel

Commentaires

Il n'y a aucun commentaire...

Poster un commentaire

Pseudo
Commentaire