La fonction SI()

Découvrons ensemble comment effectuer un test logique en utilisant l’une des fonctions les plus utilisées d’Excel : la fonction SI().

 

1. La fonction SI()

 

La fonction SI() permet d’effectuer un test logique afin de retourner une valeur donnée si le résultat de ce test est vrai et une autre valeur si ce résultat est faux.

 

2. Les paramètres

 

La fonction SI() s'utilise de la manière suivante :

 

=SI(Test_logique;[Valeur_si_vrai];[Valeur_si_faux])

 

Où :

  • Test_logique est le test qu’Excel effectue afin de déterminer la valeur à retourner. Ce test retourne soit la valeur « VRAI », soit la valeur « FAUX ». Il peut s’agir soit d’un test effectué à l’aide d’un opérateur logique (exemples : « 1=2 » retourne « FAUX », alors que « 1<2 » retourne « VRAI »), soit d’un test effectué à l’aide d’une fonction prévue pour retourner l’une de ces deux valeurs (exemple : « ESTERREUR(#N/A) » retourne « VRAI », « ESTVIDE(A1) » retourne « VRAI » ou « FAUX » en fonction de la cellule A1).
  • Valeur_si_vrai est la valeur qui doit être retournée par Excel lorsque le premier paramètre de la fonction (Test_logique) est « VRAI »
  • Valeur_si_faux est la valeur qui doit être retournée par Excel lorsque le premier paramètre de la fonction (Test_logique) est « FAUX »

 

Valeur_si_vrai et Valeur_si_faux peuvent être des constantes (exemple : SI(A1=1;"UN";"Différent de un")) mais également une fonction (exemple : SI(A1="Total";SOMME(A2 :A10) ;SOMME(B2 :B10)). Si cette fonction est la fonction SI, on parle alors d’une « fonction SI imbriquée » (exemple : SI(A1="PRODUIT A";SI(B1="TVA";C1*1,20;C1);0)). Il faut alors prêter une attention particulière aux parenthèses (chaque parenthèse ouverte doit être fermée au bon moment).

Les fonctions SI() imbriquées permettent de retourner plus de deux résultats comme le ferait une simple fonction SI(), comme le montre cet exemple :

=SI(A1=1;"resultat1";SI(A1=2;"resultat2";SI(A1=3;"resultat3";"resultat4")))

 

En suivant ce modèle, il est possible d’imbriquer jusque 64 fonctions, mais attention aux temps de traitements nécessaires lorsque les fonctions s’alourdissent.

La fonction SI() peut être schématisée de la manière suivante :

Excel formation - la fonction si

Comme pour toutes les fonctions sur Excel, chaque paramètre est séparé par un point-virgule, et les plages de données sont définies par deux points.

 

3. Compatibilités

 

La fonction SI() fonctionne sur les versions suivantes d'Excel :

 

  • Excel 2016
  • Excel 2013
  • Excel 2011 for Mac
  • Excel 2010
  • Excel 2007
  • Excel 2003
  • Excel XP
  • Excel 2000

 

4. Utilisation

 

     4.1 Utilisation simple de la fonction SI() avec l’opérateur « = »

Supposons que nous voulions constituer deux équipes avec les élèves d’une classe de 6ème. Les garçons seront dans l’équipe Verte, tandis que les filles seront dans l’équipe Rouge.

La liste des élèves est la suivante, nous disposons du prénom de chaque élève ainsi que de son sexe :

Excel formation - la fonction si

Pour déterminer de manière automatique la couleur du dossard à transmettre à chaque élève, on utilisera la fonction SI() de la manière suivante :

Excel formation - la fonction si

Pour connaître la couleur du dossard de Pierre, nous allons ainsi procéder de la manière suivante :

  • Est-ce que la valeur de la cellule B4 est égale à « G » ?
  • Si oui, alors la couleur est le « Vert »,
  • Sinon c’est le « Rouge »

Dans cet exemple, le sexe des élèves, ne peut être égal qu’à deux valeurs, soit le « G » pour garçon, soit le « F » pour Fille. Il n’est donc pas nécessaire de tester si B4 est égal à « F », car ce sera automatiquement le cas lorsqu’elle ne sera pas égale à « G ».

 

=SI(B4="G";"Vert";"Rouge")

 

Excel formation - la fonction si

 

Il suffit ensuite d’étendre la fonction à l’ensemble des élèves en double cliquant sur le petit carré noir en bas à droite de la cellule qui contient cette formule (C4 dans notre exemple).

Excel formation - la fonction si

 

     4.2 Utilisation simple de la fonction SI() avec les opérateurs de comparaison « < » et « > »

Supposons maintenant que nous voulions toujours constituer deux équipes avec des enfants, mais cette fois en fonction de leur âge. Les enfants de 13 ans et moins seront dans l’équipe Verte, tandis que ceux qui ont au moins 14 ans seront dans l’équipe Rouge.

La liste des enfants est la suivante, nous disposons du prénom de chacun d’entre eux ainsi que leur âge respectif :

Excel formation - la fonction si

Pour déterminer de manière automatique la couleur du dossard à transmettre à chaque enfant, on utilisera la fonction SI() de la manière suivante :

Excel formation - la fonction si

Pour connaître la couleur du dossard de Pierre, nous allons ainsi procéder de la manière suivante :

  • Est-ce que la valeur de la cellule B4 inférieure ou égale « 13 » ?
  • Si oui, alors la couleur est le « Vert »,
  • Sinon c’est le « Rouge »

Dans cet exemple également, il ne peut y avoir que deux issues à la question « Est-ce que l’enfant a 13 ans ou moins ? ». La valeur « VRAI » ou la valeur « FAUX ».

=SI(B4<=13;"Vert";"Rouge")

 

Excel formation - la fonction si

 

Il suffit ensuite d’étendre la fonction à l’ensemble des élèves en double cliquant sur le petit carré noir en bas à droite de la cellule qui contient cette formule (C4 dans notre exemple).

Excel formation - la fonction si

 

     4.3 Utilisation complexe de la fonction SI() avec les fonctions SI() imbriquées

En reprenant les exemples vus ci-dessus, nous voulons maintenant créer trois équipes :

  • L’équipe verte, constituée des filles,
  • L’équipe rouge, constituée des garçons de 13 ans et moins
  • L’équipe jaune, constituée des garçons de plus de 14 ans

La liste des enfants est la suivante, nous disposons du prénom de chacun d’entre eux ainsi que leur sexe et de leur âge respectif :

Excel formation - la fonction si

Pour déterminer de manière automatique la couleur du dossard à transmettre à chaque enfant, on utilisera la fonction SI() de la manière suivante :

Excel formation - la fonction si

Pour connaître la couleur du dossard de Pierre, nous allons ainsi procéder de la manière suivante :

 

  • Est-ce que la valeur de la cellule B4 est égale à « G » ?
  • Si oui, alors il nous faut nous poser une nouvelle question : Est-ce que la valeur de la cellule B4 inférieure ou égale « 13 » ?
    • Si oui, alors la couleur est le « Vert »,
    • Sinon, alors la couleur est le « Jaune »
  • Sinon c’est le « Rouge »
=SI(B4="G";SI(C4<=13;"Vert";"Jaune");"Rouge")

 

Excel formation - la fonction si

 

Il suffit ensuite d’étendre la fonction à l’ensemble des élèves en double cliquant sur le petit carré noir en bas à droite de la cellule qui contient cette formule (C4 dans notre exemple).

Excel formation - la fonction si

 

     4.3 Utilisation complexe de la fonction SI() avec les fonctions ET() et OU()

Les fonctions ET() et OU() permettent de d’effectuer le test de la fonction SI() en utilisant plusieurs critères de test. Reprenons une nouvelle fois notre exemple avec nos équipes d’enfants.

Les équipes à constituer sont les suivantes :

  • Equipe verte : les garçons de douze ans et plus,
  • Equipe rouge : les autres enfants :

Excel formation - la fonction si

Pour déterminer de manière automatique la couleur du dossard à transmettre à chaque enfant, on utilisera la fonction SI() de la manière suivante :

Excel formation - la fonction si

Pour connaître la couleur du dossard de Pierre, nous allons ainsi procéder de la manière suivante :

 

  • Est-ce que la valeur de la cellule B4 est égale à « G » ET C4 est supérieur ou égale à 12 ?
  • Si chacune de ces deux conditions est remplie alors Pierre portera un dossard « VERT »
  • Sinon, cela signifie qu'au moins une de ces deux conditions n’est pas remplie, alors Pierre portera un dossard de couleur « ROUGE »
=SI(ET(B4="G";C4>=12);"Vert";"Rouge")

 

 

Excel formation - la fonction si

 

Note : Sachez également que nous aurions pu utiliser la fonction OU() à la place de la fonction ET(). Dans ce cas, il nous aurions cherché si :

  • Il s’agit d’une fille OU son âge est strictement inférieur à 12
  • Si l’une de ces deux conditions est respectée, alors l’enfant portera un dossard « Rouge »,
  • Sinon ce sera un dossard « Vert »
=SI(OU(B4="F";C4<12);"Rouge";"Vert")

 

Excel formation - la fonction si

 

Attention, dans ce cas, vous constaterez que les Valeur_si_vrai et Valeur_si_faux sont inversées.

La fonction ET() renverra toujours la valeur « VRAI » lorsque l’ensemble des conditions seront remplies , et renverra la valeur « FAUX » dans le cas contraire.

La fonction OU() renverra toujours la valeur « VRAI » lorsque qu’au moins une des conditions sera remplie, et renverra la valeur « FAUX » dans le cas contraire.

 

 



Articles qui pourraient vous intéresser

La fonction SOMME.SI

Comment calculer une différence entre deux dates avec la formule DATEDIF (années, mois ou jours) sur EXCEL

Comment utiliser les formules DATE(), JOUR(), MOIS() et ANNEE() pour (dé)composer une date sur EXCEL

Comment vérifier que deux cellules sont identiques et forcer la saisie en MAJUSCULES sur Excel

Commentaires

Il n'y a aucun commentaire...

Poster un commentaire

Pseudo
Commentaire

Contact - Plan du site - À propos - Contact

© Excel-Formation 2018 - Excel, simplement

Haut de la page

Excelformation.fr propose de nombreuses formations pratiques et gratuites sur Microsoft Excel : des cours pour apprendre à structurer et analyser les données, des tutos sur les fonctions avancées, les formules et les formules avancées d'Excel, les formules matricielles, les mise-en-formes conditionnelles, les graphiques Excel (xls, xlsx, xlsm,…). Des tutoriels pour apprendre à automatiser les tâches répétitives (via des macro-commandes en VBA) de vos classeurs Excel.