La fonction SOMME.SI

Dans un article précédent, nous avions découvert le fonctionnement de la fonction SOMME. Nous allons à présent voir comment utiliser la fonction SOMME.SI, qui permet d'automatiser la sélection des données à utiliser pour effectuer la somme..

 

Téléchargement

Vous pouvez télécharger le fichier d'exemple de cet article en cliquant sur le lien suivant :

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.
 

 

Tutoriel Vidéo

Vous trouverez très régulièrement de nouvelles vidéos sur la chaîne, alors pensez à vous abonner pour ne manquer aucune astuce et devenir rapidement un pro d’Excel (cliquez-ici) !

 

1. La fonction SOMME.SI

La fonction SOMME.SI additionne les valeurs de chaque élément donné en paramètre lorsqu'une condition est remplie. Ces paramètres peuvent être des chiffres, des textes ou des références de cellules.

2. Les paramètres

La fonction SOMME.SI s'utilise de la manière suivante :

=SOMME.SI(Plage;Critère;[Somme_plage])

Où :

  • Plage est la plage de cellules sur lesquelles la fonction va être appliquée,
  • Critère est la condition à respecter pour effectuer la somme. Critère peut être un nombre (exemple : « 12 »), une expression (exemple : « <12 ») ou un texte (exemple : « France »).
  • Somme_plage est l'argument facultatif qui spécifie la plage des cellules sur lesquelles la somme doit être appliquée. Si cet argument est manquant, par défaut Somme_plage prend la valeur de Plage.

Comme pour toutes les fonctions sur Excel, chaque paramètre est séparé par un point virgule, et les plages de données sont définies par deux points

3. Compatibilités

La fonction SOMME.SI fonctionne sur les version suivantes d'Excel :

  • Excel 2016
  • Excel 2013
  • Excel 2011 for Mac
  • Excel 2010
  • Excel 2007
  • Excel 2003
  • Excel XP
  • Excel 2000

4. Utilisation

Exemple 1 : utilisation du paramêtre « Somme_plage »

Excel formation - la fonction somme si

Dans cet exemple, nous avons une base de données très simple dans laquelle les informations sont classées suivant deux paramètres : 

  • Le pays dans lequel les ventes sont réalisées,
  • Le prénom du vendeur

Supposons que nous voulions connaître les ventes totales réalisées par chaque vendeur. Dans un second tableau, nous ajoutons une colonne avec les prénoms, puis à l'aide de la fonction SOMME.SI nous calculons les ventes totales.

=SOMME.SI($B$4:$B$15;E4;$C$4:$C$15)
  • $B$4:$B$15 est la plage des cellules qui liste tous les prénoms,
  • E4 est la cellule qui définie le prénom qui nous intéresse,
  • $C$4:$C$15 est la plage des cellules qui reprend le montant des ventes

Notez au passage l'utilisation du symbole dollar ($) qui permet de figer les cellules si nous décidons d'étendre la formule à d'autres cellules. C'est ce que l'on appelle une référence absolue.

Il suffit ensuite d'étendre la formule vers le bas pour le résultat de chaque vendeur (en ayant bien mis les références absolues pour le critère « Plage » et « Somme_plage»).

Excel formation - la fonction somme si

Exemple 2 : omission du paramètre optionel « Somme_plage »

Lorsque le dernier paramètre (« Somme_plage ») n'est pas spécifié, il est égal au tout premier paramètre (« Plage »).

Excel formation - la fonction somme si

Note : le paramètre « Critère » peut prendre les formes suivantes :

  • Sous forme numérique : dans ce cas la somme sera effectué sur toutes les valeurs de cellules de la « Plage » qui sont strictement égales au critère. Le critère est alors saisie directement (sans guillements). 
=SOMME.SI(A1:A10;1000)
=SOMME.SI(A1:A10;B1) → « B1 » vaut 1000
  • Sous la forme d'une expression : dans ce cas la somme sera effectué sur toutes les valeurs de cellules de la « Plage » qui répondent à l'expression. Le critère est alors saisie directement entre guillemets :
=SOMME.SI(A1:A10;"<1000")
=SOMME.SI(A1:A10;"<"&B1) → « B1 » vaut 1000

Notez la manière d'utiliser une cellule dans le second exemple : la condition est entre guillement, puis l'éperluette (« & ») permet de rattacher la valeur de cellule qui contient la valeur à utiliser.

Les expressions disponibles sont les suivante

=SOMME.SI(A1:A10;"=1000") → Lorsque la cellule vaut 1000
=SOMME.SI(A1:A10;"<1000") → Lorsque la cellule est inférieure à 1000
=SOMME.SI(A1:A10;"<=1000") → Lorsque la cellule est inférieure ou égale à 1000
=SOMME.SI(A1:A10;">1000") → Lorsque la cellule est supérieure à  1000
=SOMME.SI(A1:A10;">=1000") → Lorsque la cellule est supérieure ou égale à  1000
=SOMME.SI(A1:A10;"<>1000") → Lorsque la cellule est différente de 1000
  • Sous la forme d'un texte: dans ce cas la somme sera effectuée sur toutes les valeurs de cellules de la « Somme_plage» pour lesquelles l'équivalent de la « Plage » répondent à l'expression « Critère ». Le critère est alors saisie directement entre guillemets et le dernier argument est obligatoire (impossible de sommer des textes :
=SOMME.SI(A1:A10;"France";B1:B10)

 

Article initialement publié le 7 décembre 2017, puis modifié le 10 septembre 2019



Articles qui pourraient vous intéresser

La fonction SOMME.SI

Comment calculer une différence entre deux dates avec la formule DATEDIF (années, mois ou jours) sur EXCEL

Comment utiliser les formules DATE(), JOUR(), MOIS() et ANNEE() pour (dé)composer une date sur EXCEL

Comment vérifier que deux cellules sont identiques et forcer la saisie en MAJUSCULES sur Excel

Commentaires

Il n'y a aucun commentaire...

Poster un commentaire

Pseudo
Commentaire